DTS ECO 500 battery not charging

Post Reply
donova11
Posts: 2
Joined: Sat Feb 16, 2019 8:50 am

DTS ECO 500 battery not charging

Post by donova11 » Sat Feb 16, 2019 9:05 am

After the recent heavy rains my gate started to run really slow and then not at all. The battery I had in it was about 3 years old and I assumed that was the cause of the problem as the gate worked right after installing. What I failed to notice was the "charging" light was not on, the battery has now run down after 2-3 days and stopped working again. I checked both fuses and both look fine, checked wiring and everything looks fine. The main power source runs from our bedroom to outside and underground to under the base plate so I cannot check to see if the wire covering has been compromised at any point in the length of it which is about 10m or so. Any other obvious things I could look for?

CHANTELLE
Posts: 20
Joined: Thu Jan 24, 2019 11:50 am

Re: DTS ECO 500 battery not charging

Post by CHANTELLE » Sat Feb 16, 2019 10:04 am

Good morning Sir,

You can check the following with a multimeter:
AC power coming from the house to the motor must be +/- 220V to the 16V transformer. (Cable or AC fault from house)
16V ac going from the transformer to the charger board must be between 16VAC to 17.5VAC (Transformer faulty)
Disconnect the charge board from the battery and measure the 12VDC that goes to the battery must be 12.5V to 13.8V. (Charger board faulty)
It is also a possibility that the transformer and charger board can both be faulty.
You can also bring the parts to your closest branch for testing.

donova11
Posts: 2
Joined: Sat Feb 16, 2019 8:50 am

Re: DTS ECO 500 battery not charging

Post by donova11 » Sun Feb 17, 2019 11:27 am

Thank you for the feedback Chantelle it really helped, I was able to identify an issue with the 12V DC 1.5AMP CHARGER BOARD. Looks like the board has burnt out and I need to replace it, check everything else as you advised and that board seems to be the problem child.

CHANTELLE
Posts: 20
Joined: Thu Jan 24, 2019 11:50 am

Re: DTS ECO 500 battery not charging

Post by CHANTELLE » Mon Feb 18, 2019 8:17 am

It is my pleasure.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests